Discussion:
Bug#979834: chromiums shows … nothing but errors on the console
Add Reply
nicoo
2021-01-13 15:10:02 UTC
Reply
Permalink
Control: tag -1 + moreinfo unreproducible
Control: severity -1 important

Hi Gregor,

Chiming in, even though I'm not a chromium maintainer, as I just pulled in the
new version from sid and cannot reproduce the issue, under either Wayland/sway
or X11 (in both case on my x230 laptop (Intel Ivy Bridge, “HD Graphics 4000”)

Could you try to reproduce with `--temp-profile`, to eliminate the possibility
of it being something specific to your system?
- tons of errors like
Xlib: sequence lost (0x1012c > 0x12e) in reply type 0x0!
in the terminal.
I suspect the Xlib “sequence lost” mesage is a red herring, as I get it too
even though chromium works for me :

$ chromium --temp-profile
Using temporary profile: /tmp/tmp.j0L91i0yf5
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
[93076:93076:0113/154823.164806:ERROR:vaapi_wrapper.cc(541)] vaInitialize failed: unknown libva error
Xlib: sequence lost (0x1010d > 0x10f) in reply type 0x0!
[93076:93076:0113/154823.197536:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
Xlib: sequence lost (0x10128 > 0x12a) in reply type 0x0!
Xlib: sequence lost (0x1013c > 0x13e) in reply type 0x0!
Xlib: sequence lost (0x10160 > 0x162) in reply type 0x0!
Xlib: sequence lost (0x1017c > 0x17e) in reply type 0x0!
[93076:93076:0113/154837.827426:ERROR:gl_surface_presentation_helper.cc(259)] GetVSyncParametersIfAvailable() failed for 1 times!
[93076:93076:0113/154837.836280:ERROR:gl_surface_presentation_helper.cc(259)] GetVSyncParametersIfAvailable() failed for 2 times!
[the output ends here avter I exited chromium cleanly]
After looking through https://peter.sh/experiments/chromium-command-line-switches/
and trying some switches I found that --gpu-sandbox-start-early helps
to get it back to working.
That's something, at least.

I'm downgrading the severity of the bug to “important”, as it fits: it is “a bug
which has a major effect on the usability of a package,” since chromium doesn't
start with default arguments, “without rendering it completely unusable to
everyone” as it only affects a subset of users and a workaround is available

AFAIK, “serious” should only be set by the release team or package maintainers,
or for a policy violation.
Here is what things look like for me
% chromium --use-gl=desktop
$ chromium --temp-profile --use-gl=desktop
Using temporary profile: /tmp/tmp.Ae6cGnhoWm
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
[93483:93483:0113/154905.880613:ERROR:vaapi_wrapper.cc(541)] vaInitialize failed: unknown libva error
Xlib: sequence lost (0x1010d > 0x10f) in reply type 0x0!
[93483:93483:0113/154905.910838:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
Xlib: sequence lost (0x10128 > 0x12a) in reply type 0x0!
Xlib: sequence lost (0x1013c > 0x13e) in reply type 0x0!
Xlib: sequence lost (0x10160 > 0x162) in reply type 0x0!
Xlib: sequence lost (0x1017c > 0x17e) in reply type 0x0!
% chromium --use-gl=desktop --gpu-sandbox-start-early
$ chromium --temp-profile --use-gl=desktop --gpu-sandbox-start-early
Using temporary profile: /tmp/tmp.vl1Q7azIUv
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
[93857:93857:0113/154933.600763:ERROR:vaapi_wrapper.cc(541)] vaInitialize failed: unknown libva error
[93857:93857:0113/154933.647761:ERROR:gl_implementation.cc(282)] Failed to load libGL.so.1: libGL.so.1: cannot open shared object file: Operation not permitted
[93857:93857:0113/154933.661939:ERROR:viz_main_impl.cc(150)] Exiting GPU process due to errors during initialization
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
[93900:93900:0113/154933.696658:ERROR:vaapi_wrapper.cc(541)] vaInitialize failed: unknown libva error
% chromium --use-gl=egl --gpu-sandbox-start-early
$ chromium --temp-profile --use-gl=egl --gpu-sandbox-start-early
Using temporary profile: /tmp/tmp.oynQ1dAJ1A
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
[94189:94189:0113/154959.472122:ERROR:vaapi_wrapper.cc(541)] vaInitialize failed: unknown libva error
[94189:94189:0113/154959.476500:ERROR:gl_implementation.cc(282)] Failed to load libGLESv2.so.2: libGLESv2.so.2: cannot open shared object file: Operation not permitted
[94189:94189:0113/154959.483017:ERROR:viz_main_impl.cc(150)] Exiting GPU process due to errors during initialization
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
[94210:94210:0113/154959.525251:ERROR:vaapi_wrapper.cc(541)] vaInitialize failed: unknown libva error


Best,

nicoo
Debian Bug Tracking System
2021-01-13 15:10:03 UTC
Reply
Permalink
Post by nicoo
tag -1 + moreinfo unreproducible
Bug #979834 [chromium] chromiums shows … nothing but errors on the console
Added tag(s) unreproducible and moreinfo.
Post by nicoo
severity -1 important
Bug #979834 [chromium] chromiums shows … nothing but errors on the console
Severity set to 'important' from 'serious'
--
979834: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=979834
Debian Bug Tracking System
Contact ***@bugs.debian.org with problems
Loading...