Discussion:
Bug#971754: ABI breakage from 1.4.1 to 1.4.2
Add Reply
Paul Gevers
2021-01-07 20:00:01 UTC
Reply
Permalink
Hi Federico,

On Tue, 06 Oct 2020 16:38:49 +0300 =?utf-8?q?Sebastian_Dr=C3=B6ge?=
1.4.2 broke ABI by adding some fields to the CBytePerfMon structure.
See https://github.com/Haivision/srt/issues/1592 for details.
Any progress on this? The freeze for bullseye is around the corner, and
this bug is already impacting other packages that fail to migrate to
testing due to srt not migrating.

Paul
Debian Bug Tracking System
2021-01-13 16:50:01 UTC
Reply
Permalink
tag -1 patch
Bug #971754 [src:srt] ABI breakage from 1.4.1 to 1.4.2
Added tag(s) patch.
--
971754: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=971754
Debian Bug Tracking System
Contact ***@bugs.debian.org with problems
Sebastian Dröge
2021-01-15 21:50:02 UTC
Reply
Permalink
Hi Sebastian,
On Thu, 14 Jan 2021 11:39:24 +0200 Sebastian =?ISO-8859-1?Q?Dr=F6ge?=
Upstream fixed this now by making the soversion 1.4 and from now on
guaranteeing that patch versions (1.4.0 -> 1.4.X) do not break ABI.
It would make sense to backport that fix and then rename the
library package accordingly to libsrt1.4.
For gst-plugins-bad1.0 only a binNMU would be needed once this is
all
sorted out here.
Can you do this please? srt is orphaned, your package depend on it,
could you please help us get us out of this situation? (if this
happens soon, we'll accept the transition to fix this).
I'll try to have some time for that this weekend.

Loading...